[jira] [Updated] (AVRO-1543) libboost_zlib library is not detected but is required

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Updated] (AVRO-1543) libboost_zlib library is not detected but is required

Krishnan Sundaram (Jira)

     [ https://issues.apache.org/jira/browse/AVRO-1543?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ismaël Mejía updated AVRO-1543:
-------------------------------
    Fix Version/s:     (was: 1.10.0)

> libboost_zlib library is not detected but is required
> -----------------------------------------------------
>
>                 Key: AVRO-1543
>                 URL: https://issues.apache.org/jira/browse/AVRO-1543
>             Project: Apache Avro
>          Issue Type: Bug
>          Components: c++
>    Affects Versions: 1.7.6
>         Environment: Windows?
>            Reporter: Sean Middleditch
>            Assignee: Thiruvalluvan M. G.
>            Priority: Major
>
> Standard builds of Boost with the iostreams library and zlib support build two separate libraries, libboost_iostreams and libboost_zlib. Avro is properly setup to detect and link in the former but not the later, meaning that Avro cannot be build out of the box without customizing either the Boost build or Avro's CMakeLists.txt.
> Another alternative change may be to remove Avro's hard requirement on zlib support in Boost's iostreams library, especially as stand-alone Boost builds will not include zlib support. Avro could either require its own flag for zlib support (being explicit is good, so this would be good) or detect if Boost was compiled with zlib support during CMake generation time. If Avro does not do either of these, it needs to be updated to link in libboost_zlib.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)