[jira] [Comment Edited] (AVRO-3120) Support Next Java LTS (Java 17)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Comment Edited] (AVRO-3120) Support Next Java LTS (Java 17)

Dave Cole (Jira)

    [ https://issues.apache.org/jira/browse/AVRO-3120?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17356242#comment-17356242 ]

Ismaël Mejía edited comment on AVRO-3120 at 6/3/21, 7:58 AM:
-------------------------------------------------------------

It seems there is a workaround for this so we can solve it for the CI.

Reference for the future:

{code}
export MAVEN_OPTS="--add-exports jdk.compiler/com.sun.tools.javac.api=ALL-UNNAMED \
--add-exports jdk.compiler/com.sun.tools.javac.file=ALL-UNNAMED \
--add-exports jdk.compiler/com.sun.tools.javac.parser=ALL-UNNAMED \
--add-exports jdk.compiler/com.sun.tools.javac.tree=ALL-UNNAMED \
--add-exports jdk.compiler/com.sun.tools.javac.util=ALL-UNNAMED"
{code}


was (Author: iemejia):
It seems there is a workaround for this so we can solve it for the CI

> Support Next Java LTS (Java 17)
> -------------------------------
>
>                 Key: AVRO-3120
>                 URL: https://issues.apache.org/jira/browse/AVRO-3120
>             Project: Apache Avro
>          Issue Type: Improvement
>          Components: java
>            Reporter: Ismaël Mejía
>            Priority: Major
>
> With the upcoming release of the next Java LTS version (Java 17) we should validate on Apache Avro that it works correctly in this Java version.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)